Log in

No account? Create an account
Many a mickle maks a muckle

> Recent Entries
> Archive
> Friends
> Profile

August 3rd, 2005

Previous Entry Share Flag Next Entry
04:27 pm - Hello, tentacle support?
Subject line from here, via waistcoatmark. Silly, work-safe.

I am trying to establish a web site and put a perl script to run a Wiki on it. I have uploaded the software correctly, unzipped it, extracted the tar archive and put the wiki.pl script into ~/htdocs/cgi-bin/ . I have made sure that both the wiki.pl script and the cgi-bin directory have 755 permissions. When I visit http://www.appropriatesitename.com/cgi-bin/wiki.pl then it does not execute the script, it merely displays the code of the script in the browser. However, when I open a shell, cd to the appropriate directory and execute perl wiki.pl from the command line, it produces a perfectly-formed HTML page that I would expect to see. I do not believe there is anything further I need to do in order to enable running scripts on the web site.

Any advice, please? aTdHvAaNnKcSe to anyone who can help.

ETA: We now think it's a problem at their end. Their engineers are looking at it and hope to have sorted it out in 24 hours. If not, I shall phone again. Thank you for the suggestions anyhow, but I doubt there's much anybody can do about it from this end in that case...
Current Mood: disappointeddisappointed

(28 comments | Leave a comment)


[User Picture]
Date:August 3rd, 2005 04:28 pm (UTC)
Further to wise comments from pseudomonas above about web server configuration: Try renaming your script to be called wiki.cgi, having first ensured that the first line of the script is "#!/usr/bin/perl" (may vary on some systems). This is a (benign) hack, but works for some configurations.

[User Picture]
Date:August 3rd, 2005 04:35 pm (UTC)
Tried that before I posted. :-) (Just tried it again. No joy.)

The issue is with the permissions. Apparently they want the permissions on the file to be set to 700, but if you do that, then you're not going to be able to view the file from the outside world. :-/ (Or perhaps you are, if they have some hack at their end. Idunno.) Setting them to 755 just gives you the "read rather than execute" problem still.

Hey ho!

> Go to Top